Tales of Vesperia PS3 fan translation project hits milestone

July 18, 2011 / 07:14 PM EDT / (@salromano)

After half a year’s work, the team originally behind the Tales of Graces F fan translation project have finished “initial translation” of the PlayStation 3 version of Tales of Vesperia.

That means they’ve got all the text translated to English. Though, the team’s work is “far from done.” To make sure the translation patch is ship-shape when it releases, the team still has to verify the translations, give them a contextual review, and begin editing. They’ve just now entered the translation verification phase.

A release has not yet been pinned for the patch, but the team provided some proof of concept videos and images.

Tales of Vesperia PS3 English Translation

Share and Discuss
Guidelines
  • http://myanimelist.net/profile/PrinceHeir# PrinceHeir

    i wonder how will they implement this on the PS3 with all the firmware updates and all :\

    still awesome work :P

    shame on you namco

  • BizarreJelly

    Blah blah blah tidal wave!

  • whiteferrero

    :D yes, how will they implement this i wonder?

  • RedWolfe

    Kudos to these guys for actually doing this but I’m actually more curious about how they’re actually going to implement this.

  • TheDarkCloud

    This is a very nice new. I prefer Vesperia before the other. I do not understand, you get off a patch online? Or they make the game with English subtitles and will hit the market when they finish?

  • Sal Romano

    For those confused as to how you’ll implement this, here’s what the site says you’ll need:

    - A PS3 that has not been updated beyond firmware version 3.55
    - A retail copy of Tales of Vesperia for the PS3.
    - A USB drive with at least 128 MB of free space. It will not require any sort of “jailbreak” usb device.

    • RedWolfe

      @Sal Romano: Well…shit.

      I’m at whatever the most recent firmware is. I always update my PS3 to the latest firmware :\

      • whiteferrero

        @RedWolfe: great that it doesn’t require jailbreak! i want my ps3 pirate free as much as possible. i just hope that they can get this to work on the latest firmware.

  • LordKaiser

    Too bad that my slim came with 3.60…

  • RyougaZell

    Argh… I have the Japanese disc… but my firmware is also up to date -___-

    They really need to find a way to run it regardless of firmware and safely so they aren’t blocked due to illegal content.

    Wish Sony allowed them to use this patch legally… (dream on)

    • Chainermike

      @RyougaZell:

      I see no reason why Sony and/or Bandai Namco can’t just sign and verify it to work like every other DLC. Also they could then put it on PSN and even charge a small amount for it, I know I’d pay.

      There are ways of doing this right however i think the only thing holding them back is that it has never been done before, therefor there is no standard procedure.

      I just see this as a needed step for console “modding”. If this was on the PC the translation would be available to everyone with the game, not just those with hackable consoles(I know it doesn’t need to be JB but it’s at the firmware for it)

  • Leonix7791

    Damn i hope they can figure out how to implement this on every FW and it doesn’t require any JB device which is good news…means BR friendly lolz…now if Namco Bandai see this and decided to sign a deal with them…PROFIT :/

  • Revorse

    Man, seeing this is English makes me sicker knowing that I won’t be able to play it

  • go-go-boy

    damn this sweet man i am proud of the people responsible for this i have never played a tale game but boy i will try this one out even though i really want to play xillia. namco bandai its a shame when people who don’t even work for you do a better job.

  • MooMetal

    Daaaaaaaaaaaaaaaamn, my PS3 is 3.66.
    Life sucks.

  • DjangoRaijin

    If you restore it will it revert to before 3.55. Yea right Im not deleting all my stuff for one game they should make it support a newer update or something.

  • talesoffan

    I have a 3.56 fw PS3, which sucks right now. Really hoping a new custom firmware comes out just so I can play this in English.

  • dart2087

    Namco should publish this patch!

  • Mousse Effect

    This is a great projet, but it won’t work for 90% of people who want to play this game as you need a 3.55 PS3.

    There is an operation akin to Op. rainfall dedicated to localize Vesperia, every one should participate in it : http://vesperiaps3.blogspot.com/2011/06/campaign.html

    Also, Namco (Facebook) and Sony (Psblod) should be made aware that this patch exists and that they now just have to “legalize” it – Yakuza 3 was localized with jap dubs and it sold over 400.000 overseas : there is no need for Namco to pay for dubs.

    A lot of great localization companies (NIS, Xseed) could take it off their hands it if they don’t want.

  • celestria

    weee im glad i never updated^^^ that’s why i read news^^

  • http://Flickr.com/mdemolish mdemolish

    wOw,,I hope is better than Xbox 360

  • LeoV

    meanwhile …
    Valkyria Chronicles 3 has totally forgotten

    • Sal Romano

      @LeoV: It’s actually pretty funny, considering the hacking community is much greater on PSP.